Zapisz się na newsletter i odbierz DARMOWY EBOOK: 10 najprzydatniejszych porad excelowych

środa, 11 czerwca 2014

Obliczanie średniego czasu trwania (biegu na 10 km)


Ostatnio napisała do mnie Dorota - czytelniczka mojego bloga. Zadała ona pytanie:

Muszę w pracy wyliczyć średnią z kilku dni (ok. 100), dla próbek cito. (...) Do wyliczenia czasu trwania analizy pojedynczej próbki wzorowałam się na artykule Obliczanie czasu pracy, ale jak z tego wyliczyć teraz średnią dla wszystkich próbek?

W tym artykule pokażę zatem jak obliczyć średni czas trwania danej czynności. Omówię to na przykładzie biegu na 10 km. Będę potrzebowała do tego listę uczestników biegu (zawodników), a na niej godzinę startu i końca biegu.

Oto dane:

Obliczanie średniego czasu (biegu na 10 km) - formatka

Najpierw obliczę czas biegu poszczególnych zawodników. W tym celu należy w komórkę D2 wpisać następującą formułę:

=C2-B2

Po skopiowaniu jej do pozostałych komórek (D2:D7) mogę już obliczać czas średni. Robię to następująco (komórka D9):

=ŚREDNIA(D2:D7)

Wynik jest następujący:

Obliczanie średniego czasu - formatowanie minut

W przypadku średniej warto jednak wynik podać tak, by były widoczne sekundy (średnia często bywa liczbą z miejscami dziesiętnymi). Polecam więc użyć formatowania czasu z sekundami (obrazek poniżej). Aby wywołać okienko formatowania komórki użyj skrótu klawiszowego Ctrl + 1 (jeden). Pojawi się następujące okienko (wybierz opcje takie, jak na rysunku):

Obliczanie średniego czasu (biegu na 10 km) - formatowanie sekund

Oto efekt:

Obliczanie średniego czasu (biegu na 10 km) - wynik

I okazuje się, że średni czas biegu na 10 km zawodników z listy to prawie 54 minuty, a nie 53! Opłacało się więc zmienić formatowanie ;)

Gotowe!

I wersja wideo:



Plik do pobrania: MalinowyExcel_Średni_czas.xlsx



Related Posts Plugin for WordPress, Blogger...

1 komentarz:

  1. Super przykład. I ta zmiana formatowania zmieniła wynik.

    OdpowiedzUsuń